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HYPACK SHELL

New feature: Visual Geodesy with dynamic webmap. The Project Wizard now has an
alternate and simpler way of setting up geodetic parameters when you are using UTM
Grids and US State Plane NAD-83. This interface allows you to set up geodesy with just a
click on a dynamic map!

To set up geodetic parameters using Visual Geodesy:

Open the Project Wizard, which is either when HYPACK® starts, or click File-> Project
Wizard.

Select “Create New Project” and click [Next]. This will take you to the new project creation
page.

Give a project name and click [Next]. Next is the geodesy page.

On the Geodesy page, select Click on Map in the Selection Mode drop-down. This opens
the World Map where you can click on the area to set up your geodetic parameters. You

can see the Lat-Long value on the bottom of the window along with grid area and zone
information.

An interactive dynamic web map will appear. You can turn on and off the zone grid lines
by clicking the “Show Zone Grid” button and vice versa if you are using UTM Grids. You
can zoom in and out by using the mouse scroll wheel and scroll bar in the map window.
You can also pan around the map area by dragging the map using the mouse. You can
see Lat-Long in the bottom right of the map window, while UTM grid and zone info can be
seen in the bottom left of the window.

If you are using the State Plane NAD-83 grid, you can click on the [State Plane] button
and US state plan zones will appear. You can zoom in and out like explained in the
previous step. Select the zone of your choice and your selection will appear at the bottom
left of the map window. You will need a *.kml file for the state plane system in the datum
folder under the HYPACK® installation directory. File name is “StatePlaneNAD83.kml”.

When the information is correct for your project, click [Set Geodesy]. This will take you
back to the geodesy page in the Project Wizard, and you can see the updated geodesy
settings.

When you are done with Geodesy settings, click [Next].
You have created the project and set up your geodesy with just click on a map.

Added a dialog that accepts various user and file inputs to produce either a
Contour Line Bathymetry or an Environment, Seabed and Beach AML compliant
chart. Source data extending beyond boundaries of chart is automatically clipped to
interior of chart. Inputs include defining various chart and feature level attributes as well
as specifying files for importing of data from Border, Planned Line, XYZ, Target Database,
DXF and KML file formats.

Added a dialog that accepts various user and file inputs to produce either a
Contour Line Bathymetry or an Environment, Seabed and Beach AML compliant
chart. Source data extending beyond boundaries of chart is automatically clipped to
interior of chart. Inputs include defining various chart and feature level attributes as well
as specifying files for importing of data from Border, Planned Line, XYZ, Target Database,
DXF and KML file formats.




LINE EDITOR

Entire lines can now be moved and rotated:

Added ability to click anywhere on a line, grab it and move.

Added ability to select a pivot point on a line and rotate the selected line.

Added keyboard shortcuts, M keypress to move line, R keypress to rotate line. To enable
keyboard shortcuts, user must first use the menu or click on a line node in the shell.

The M and R keys can be used as toggle switches and enabling move/rotate mode will
disable the other mode and addition of new points.

These functionalities can also be accessed through the menu by right-click on the line in
tree view of the Line Editor.

PREPARATION

GEODESY

Added checkbox in Time Variable transformations to allow height transformation using
the datum transformation parameters. When the checkbox is checked, all height
calculations will be vertically transformed based on the datum transformation parameters.
Added new dialog in Tools, “Datum Height Calculator” to allow users to calculate the
height correction using the datum transformation parameters by entering a Latitude and
longitude value, this generated value will be applied to “Orthometric Height Correction”
Updated “Orthometric Height Correction” label to “Datum Orthometric Height Correction”
when the fudge factor is generated using the Datum height calculator.

Added an edit box in Grid Conversion dialog to display the datum vertical shift.
Combined HAS/RAW file filter in Tools->Import HSX/RAW data.

HARDWARE

New Feature: We’ve added the new dialog Vessel Configuration Wizard, which
allows users to quickly save and load vessel configurations from the C:\HYPACK
Store\Vessels folder.

To use the Vessel Wizard, from the HYPACK Shell click Preparation -> Hardware Setup.
In the HYPACK Combined Hardware, click File -> Vessel Wizard. The Vessel Wizard
Dialog Box opens.

HYPACK Combined Hardware
File Options Help
MNew Mobile Offsets Vessel Shape  All Offsets
st > e Device Type Tracking Point
Export > v (®) Survey Devices (ZJHYSWEEP Devices () Side Scan Devices Starboard ’
Vessel Wizard... Forward ’
MV Ne
G2 MALL Maobile Name |Boat |
Exit
Available Installed
Description Version HYSWEEP Inter
- Applanix POS b
3D LR Indicator 16.1.2.0 ~
ANCP Driver 19.1.0.0
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> Click [Save] to save the currently opened project's hardware configuration to the
Vessels folder.

> To load one of the listed vessel configurations, click the name of the configuration and
click [Open].

> To delete a vessel configuration, click the name of the configuration and click [Delete].

= VesselWizardDlg - [m| X

Save FileMame  |Default
Dredge-NY Harbor
LIDAR Test Survey
Multibeam-Great Lakes
Sidescan-Hull Mount
Sidescan-Towfish
Survey Launch 3

Delete

¢ In the HYPACK Combined Hardware, users can now save device offsets to a PDF.
To do this, enter your device offsets in the HYPACK Combined Hardware window, then go
to the All Offsets tab and click Export to PDF. Give the PDF file a name and select the




save location.

HYPACK Combined Hardware - [m} x
File Options Help §l Export to PDF...
E‘{?B Hardware Mobile Survey Device Offsells Al Offsets
B- Boat ) Device Type Starboard Forward  Vertical Yaw Pitch Raoll Latency
= Applanix POS M/V 5
@ Applanix POS MV Survey Devices
= H$§WEEPI ot Applanix POS MV -4.300 -0.630 2530 0000 0000  0.000  0.000
S HYSWEEP S nierace Applanix POS M/V -0.630 250 0000 0000 000D 0.000
: urvey HYSWEEP Interface -4,300 -0.630 2530 0000 0000 0000 0.000
(&) NORBITWEMS : -
@ Applanix POS/MV Ne Multibeam Devices
PP NORBIT WBMS Sonar Head 1 -4.800 -0.630 2530 2500  -0.500 0100 0.000
Applanix POS/MV Ne...  MRU Offsets -4.800 -0.630 2530 000D 0000 0000 0.000
Applanix POS/MV Ne... Heading Offset (V... 0.000 0.000 0000 000D 0000 0000 0.000
< >
The following image shows an example PDF containing the entered offsets.
= hware.pdf - Adobe Acrobat Pro DC
File Edit Window Help
Home Tools Document d B EQ /1 3 @ C® 2 - ﬁ P e 7
Halifax, Device Offsets
Device Type Starboard Forward Vertical Yaw Pitch Roll Latency
Survey Devices
[Applanix POS M/V -4.800 (m) -0.630 (m) 2,530 (m) 0.000 (deg) 0.000 (deg) 10.000 (deg) 0.000 (sec)
[Applanix POS M/V -4.800 (m) -0.630 (m) 2,530 (m) 0.000 (deg) 0.000 (deg) 10.000 (deg) 0.000 (sec)
HYSWEEP Interface -4.800 (m) -0.630 (m) 2.530 (m) 0.000 (deg) 10.000 (deg) 10.000 (deg) 10.000 (sec)
Multibeam Devices
NORBIT WEMS Sonar Head 1 -4.800 (m) -0.630 (m) 2.530 (m) 2.500 (deg) -0.500 (deg) 0.100 (deg) |0.000 (sec)
[ pplanix POS/MV Network MRU Offsets -4.800 (m) -0.630 (m) 2.530 (m) 0.000 (deg) 0.000 (deg) l0.000 (deg) 10.000 (sec)
|applanix POS/MV Network Heading Offsat (Yaw) 0.000 (m) 0.000 (m) 0.000 (m) 0.000 (deg) 0.000 (deg) j0.000 (deg) 0.000 (sec)

SURVEY DEvICE DRIVER UPDATES

e ScaledDGH.dIl: Added options to interpolate pitch/roll readings to the origin point,
to a mobile's current position, or to a user-defined offset.
To use these option, from the HYPACK Shell click Preparation -> Hardware Setup. In the
HYPACK Combined Hardware window, add ScaledDGH.dIl, then open the Setup window.
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Check the box next to “Interpolate Reading with Pitch/Roll”, then select the reference

point.
B Setup — O X
[“] Scale Reading Reading T est
Sealing | Draft |

Fiaw [méamp | Real

Min Interpolate Reading with Pitch/Roll

(®) Ta Origin [Device Offsets)

Max O To Mobie

[ Filter Raw Values Crane
Min [50 | Max [100 (O User Defined
Alarm Range [Use 0 For Mo Alarm) 10.00
Min |00 | Max |00 10.00

OK Cancel

e Subbot.dll: Removed the base gain setting from the Subbot.dll window in Side
Scan Survey, since its function is redundant and caused undesired side effects.
Gain can still be applied in the Analog Monitor and display controls.

7 Sub-Bottom Driver-NUL: - Analog (NI USB) — O Sub-Bottom Driver-D:\HYPACK Projects\Sub Bott

ﬁ? IE:_J P Bass

e Sbhg.dll: Added the “Calculate tides when solution status is at least...” slider in the
SBG Setup window, which allows users to set the minimum solution level to record
tides. These choices are similar to the alarm threshold conditions.




To use this function, add sbg.dll in the HYPACK Combined Hardware, then open the SBG
Setup window. Drag the slider to the condition you want, then click [OK].

SBG Setup *

[JUse Hypack Time Stamps Shows alarm when solution status iz at or below..

utput to recize point positioning with fixed ambiguities
(o upp 5ERE Preci i itioni ith fixed ambiguiti

(] Use PRS signal for timi Precize point positioning with float ambiguities
3@ signal for timiny . )
g g Irteger RTE. ambiguity solution [2ems RTE)

Seral Port, COMI1 Floating RTK ambiguity solution [20 cms RTE]
Omristar WBS position [L1 sub-meter)
[ Display Debug Messages SBAS satelite used for differential corections
Alam thresholds Standard pseudorange differential solution

To dizable, enter 0 Single point solution position

Unknown solution type

Lat Accuracy fill3 Mo valid zolution available
Lon Accuracy ftl1s B Never
Height Accuracy ftUs Calculate tides when solution status is at least...
GPS Lat Accuracy fts Precize point positioning with fised ambiguities
Frecize paint pozitioning with float ambiguities
GPS Lon Aceuracy fill3 Iteger RTE. ambiguity solution [2ems RTE)
GPS Height &ccuracy FLIS Floating RTE. ambiguity solution [20 cms RTE)
Omrigtar WBS pozition [L1 sub-meter)
Heading Azcuracy deg SBaS satelite used for differential corections
Standard peeudorange differential solution
Flall &ccuracy -
m deg Single point zolution pogition
Fitch Accuracy deg Unknown solution bype
W always
Y aw Accuracy deg
Diff Carr Age sec
S atellite Count D Cancel

e Subbot.dll: Users can now separately set the Trigger and Data terminal mode
inputs from the I/O Channels window associated with the Analog Monitor in
HYPACK Survey. These options work for National Instruments devices like Fugro.

The Trigger and Data terminal mode dropdowns are populated with options that are
based on what the connected device(s) report back as their capabilities. Note that if you
do not have a National Instruments device connected, all of the dropdowns will be empty.

For the terminal modes, potential options include Referenced single-ended, Non-
referenced single-ended, Differential, and Pseudodifferential mode.
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The Coupling mode options are AC or DC.

(Administey /O Channels *

Analog M [] Side Scan Input Voltage Voltage Limits
Data Input Trigger |None -5 5 Select channel
=r |None -5 5 Select channel E
=| | None -5 5 Select channel |
Channel |None -5 5 Select channel o-10V |

Sub-Bottom

L
Input Trigger 1 |Devl/ai0 w D EI Limits: -10.0v10.0v - l
-5 :Il

Input Trigger 2 |MNone ~ 5 Select channel
. |
Output Trigger 1 | Dev1/ao0 ~ D EI Limits: -10.0v/10.0v  [ration

Qutput Trigger 2 Mone w5 5 Select channel 1
Data Channel 1 | Devi/ait “l[5 ][5 ] umits: -0.0v/20.0v b ’
Data Channel 2 | None ~| |5 5 Select channel -
[] Event Output Mone 5 5 Select channel 4 ‘
Trigger terminal mode Data terminal mode Coupling mode
Referenced single-ended ~ | | Mon-referenced single-ended  ~ | |DC w E_G.
Messages {§ Manually override channel sample rate (Hz) Ma: 100.0 kHz !?Iyes ;
Reduce signal ghostin .
O gnal ghosting lApply ‘

[JEnable low frequency alias rejection Il

Set Custom Labels Cancel

To use this new feature:

From the HYPACK Shell, click Preparation -> Hardware Setup to open the HYPACK
Combined Hardware window. Add subbot.dll, and select a National Instruments device
(ie: Fugro).

Back in the HYPACK Shell, open HYPACK Survey. In the Analog Monitor window under
the Settings section, click [I/O Channels] to open the 1/0 Channels window. Check the
Sub-Bottom checkbox, then select the desired input from the Trigger terminal mode, Data
terminal mode, and Coupling mode dropdowns. Click [OK].

HYSWEEP® DEvice DRIVER UPDATES

R2Sonic Devices: The HYPACK 2023 Q1 release introduced the option to log TruePix
compressed water column data for R2Sonic HYSWEEP devices. However, it was found
that a UDP pass through is necessary to correctly transfer data from HYSWEEP to the
water column logger.

In this update, the Pass Through Port field has been added to the R2Sonic Setup
window. When logging TruePix water column data, you need to specify the UDP




port for HYSWEEP Survey to water column logger pass through.

|B | R2Sonic Setup  — [m] X

Data Format
(® RZSonic

() Seabat 81P Compatible

Local IP Address

1001102

Log Sidescan Data
["]Log Snippet Data
] Log TruePix Data

[ Log Water Column Data
EA TruePix Water Column

Pass Through Port

Dual Head

Co

Now, use the following steps when setting up HYPACK Combined Hardware and the
R2Sonic Sonic Control software when logging TruePix water column data:

In the HYPACK Combined Hardware setup window, select HYSWEEP Devices and
choose from the following R2Sonic devices: R2Sonic Dual Head 2020, Dual Head 2024,
SONIC 2020, and SONIC 2024. Double click the device name to open the R2Sonic Setup
window. Check both “Log Water Column Data” and “TruePix Water Column”. Enter the
value of the pass through port. The default pass through port is 5656, which should work
for the majority of situations. If data is not transferring, try 5657 instead.

In the R2Sonic Sonic Control, open the Operation Settings window and make sure
TruePix Enable is checked in the Sonar tab, and Magnitude+Angle is selected as the
TruePix data format in the Imagery tab.
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The compressed data will be logged and displayed in the HYSWEEP® Water Column
Logger window while HYSWEEP® SURVEY is running.

E Opera

Sonar Display magery Robo Sonar  Display Imagery Robo
TruePix A
Dala Fomnat Sonic 2024 Sonar1 |  Sonar2
i Frequency fkHz) 300 ~ | 400
(®) Magnitude=Angle (690kB/s max) Ping Rate Limit {Hz) 30 v|
i Sector Coverage (Deg) | 140 ~ 120
Gating 3 5
O of Sector Rotate (Deg) w
@ Bathy gate max Min Range Gate {ft) 0 0
() Bathy gates min & max Bottom Sampling Equiangle quad ~ |
Miggion Mode Down, Bathy Nomal V|
Water Column ol Stabilze
Data Format - -
Pitch Stabilize
(O Magnitude (35MB/s max) =
(@) Magnitude+Phase (FOMB/s max} = 1 ¥
TruePix Enable [} |
TSTppet EnabE :
Video Capture nippets Enable L
Water Column Enable [l
Saveto | | | Browse ‘ Intensity Enable
Frame Rate
O 2Hz O 10H ® 24Hz O 30 Hz
Snapshot
Saveto | | Browse ‘
Close Close

TPU EDITOR

* RTF reports generated from the TPU Editor now include a Devices Info table, which
lists the selected positioning, MRU, multibeam, and heading devices.
To generate an RTF report, after choosing each device, click File -> Save RTF Report.

TPU Report - Single Beam Mobile

Sensor info

‘ Project Name | Single Beam Mobile | Physical Offsets Sensor Offset Uncertainty

| Date Report Generated |o7iz6i23 13:41:11 | Position MRU Transducer |Position MRU Transducer
Starboard 0.00 0.00 000 000 0.00 000
Forward 000 0.00 000 000 0.00 000
Vertical (+ Down) 0.00 0.00 0.00 0,00 0.00 0.00
Survey Speed () 50 Fied Heave Uncertainy (m) 005
Speed Uncertainty (m's) 01 Heave (% of Heave Ampliude) 5
Roll Offset Angle of Transducer (deg) 000 | Roll Sensor Uncertainty (deg) 0025
Pitch Offset Angle of Transducer (deg) _ [0.00 | Piich Sensor Uncentainty (deg) 0025
Heading Offset Angle of Transducer (dgg) [0.00 | Roll Ofiset Uncertainty (dag) 005
Transducer Draft (m) 1.050 | Pilch Offsel Uncertainty (deg) 050

General Tuning Parameters ‘Yaw Offset Uncertainty (deq) 050

Angular Coverage (deg) 175 Ampitude/Phase Measurement ‘ 12

Crossover (samples) Positioning System Uncertainty (m) dmrs__|0.3 Posilioning Time Lag (xs) 020

Maximum Ping Rate (Hz) 50 Amplitude Detect Denominator g Heading Uncertainty (deg) lo3 MRU Time Lag (s} 0.005

Along Track Beam Width (deg) o7 Transducer Time Lag (s) 0.005

Across Track Beam Width (deg) 10 Estimation Graph Parameters Draft Uncertainty (m) [n 02 Latency (s) 0.000

Puise Length (ms) 0050 Number of Beams 400 ‘Squat Uncertainty (m) [00z

Seclor Steering Angle (deq) 60 Depth of Botiom (m) 20 Loading Changes (m) [00z

Frequency (kHz) 2300 Roll Angle (deg) 0.0

Receive Bandwidth (kHz) 6 Pitch Angle (deg) 00

Range Sampling Resolution (m) 00125 Devices Info
Device Type Device Name

Speed of Saund (mis) 1629 Sound Speed Sensor Uncertainty |0.50 Positioning System Cada Octopus F180/175 DGPS

(mis) MRU System Cada Octopus F180/175

Peak.1o-Peak Swell (m) 10 ?r;ﬂ?ce Sound Speed Uncedainly 025 ‘Muilbeam 3600, 230kHz.

F-A Seafloor Siope (dea) 00 ‘Soalio- Temporal Variation (ws) 100 Hoading System [Yeckor 108

P-S Sealloor Slope (dea) 00 Thickness of S-T Layer (m) 100

Water Level Uncertainty (m) 002 Sound Speed Uncerainy Beyood SV 000

Spatial Tide Prediction Uncertainty (m) 002 Maximum Depth of SV Profile 210
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¢ In the menu, a blue checkmark is now displayed next to the selected positioning,
MRU, multibeam, and heading devices.

B U Editor - TPEini* - X
File = Positioning Systems =~ MRU Systems  Multibeams

Heac Generic RTK
Generic DGPS

(7]
fi]
3
1]

Applanix POS MV RTK
Applanix POS MV DGPS

Coda Octopus F180/175 RTK
Coda Octopus F180/175 DGPS
Hemisphere Vector RTK
Hemisphere Vector DGPS
Trimble AgGP5 132 DGPS

ey
Il
R

A

C-Nav
Fugro Marinestar
VERIPOS

THICKAESS O S=T Layer (m)

RHEREHE

Iy
=]

i

Sound Speed Uncertainty Beyond 5V Profile

[
o

1 Maximum Depth of SV Profile

DATA ACQUISITION

SURVEY

e Users can now choose to name LOG files with ISO Standard (European) date
format (YYYYMMDD). This format also applies to RAW, HSX, HS2X and XYZ files.
To use this option, in HYPACK SURVEY click Options -> Project Information. In the
Project Data window, click ISO Standard Date (YYYYMMDD), then [OK]. Subsequent
LOG, RAW, HSX, HS2X, and XYZ files are named using date and time in the following
format: YYYYMMDD_HHMM file type.
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In the following example on the right, LOG and RAW files are now named using the new

date standard.

7 Project Data[2463]

Settings

— O

Project |Ha|ifax

b |

Area |

Boat |

| [CJoverride Project Path

Surveyor |

() Standard HYPACK Filenames

(O Long Filenames

(O CHS Filenames

(O Julian Day as Extension

() Other Extension ext

I (®) 150 Standard Date (YYYYMMDD) I

[[Juse File Prefix

L

[C] Append Julian Day to Prefix

[oc ]

SIDE SCAN SURVEY

e Geodesy ini values are now written into HSX header in side scan.
e Users can now select the default target group to add targets to when marking

targets in Side Scan Survey. To use this new feature:

X

| C:\HYPACK 2023\projects\Halifax\R L5,

Project Items ) x |

Project Manager ProjectItems Sounding Colors

F N Options > Views ~

Item path
=) D Raw Data Files
LY
] 2023__170.LOG C:\HYPAC...
=2 HSX_06192023.L0G C:\HYPAC...
. j RAW04122023.L0G C:\HYPAC...
Eﬂm Y RAW1201.L0G C:\HYPAC...
=y M| "j RAW20230619.L0G C:\HYPAC...
O u 20230619_1348.RAW C:\HYPAC...
O u 20230619_1350.RAW C:\HYPAC...

Du 20230619_1350_0001LRAW  C:\HYPAC...
| ﬁmmmg_msu_uuuz.mw C:\HYPAC...

[#[][:2%] Edited Data Files
# [J[E23] Sorted Data Files

E?ii”ﬁ Project Files
= i Golden Sounding

O @ Archive

1. Open Side Scan Survey from the HYPACK Shell by clicking Survey -> HYPACK Survey

and Side Scan Survey.

2. In the Side Scan Survey window, click Targets -> Target Parameters...
This opens the Side Scan Options window.
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3. Inthe Side Scan Options window, select Targets from the list on the left. From the Default
Target Group dropdown, click on the target group you want your targets to be saved to.
As you can see, the target groups in the project are listed i in the menu. Then, click [Close].

Side Scan Options b4 E E [B Praoject Files

Colors Targets
Gain
Display Auto name style

Bottom Tracking
Coverage Map (®) Default style (HH:MM:SS)

Altitude Window (O NOAA Style (DDD-HHMMSSC)
Targets

Device Selections Capture adiacent pinas

Automatically capture 30% of swath

JPEG options
When marking a target, both a GecTIFF and a JPEG are created.
GeoTIFFs will be displayed in the shell, are always slant range

Georeferencing

) Show water column [J Add range ruler to image

(® Slant range correct

Default Target Group 55 SURVEY e .@ S5 SURVEY
Hyscan o}t = § “[] test group
| SHELL I
Default Values Iﬁl‘ HH :::p::: =
HYSWEEP® SURVEY

« HYSWEEP® Water Column Logger now properly supports and displays TruePix
compressed water column imagery. See the addition of the Pass Through Port field in
R2Sonic Device Setup in the HYSWEEP Device Driver Updates for more information on
setting up TruePix logging for R2Sonic devices.

DATA PROCESSING

64-BIT SINGLE BEAM EDITOR (SBMAX64)

o Offline Statistics added from File Menu (has list with median.avg/std dev values and
draws histogram underneath).

e Sounding Migration added from File Menu.

e Echogram window right click and drag to pan works like it does in Profile Window.

* Added message to Device Offsets that the place to adjust tide is in raw file adjustments
e Added note to device offsets stating what units everything is in.

ECcHOGRAM WINDOW

e Users can now export signal intensity data from echograms, and a new Export
button has been added to the SBMAX64 echogram window to create these ASCII
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* txt files.

B! Echogram - Depth — ] X

] Aut Depth 1 pigitizing Depth 1 Signal Scale
%5 o
bl (& o m uto @ Digitize om igitizing Dep! el - Export

1-302P38.RAW X=1084525.8 Y=256824.2 7=36.2

To us this new function, you will need to first load a *.raw file and open the data in the
echogram.

From the HYPACK Shell click Processing -> Single Beam Editor (64 bit), and the
SBMAX64 window opens. Click Load Survey, and in the Raw folder select the LOG file
and click [Open]. Click any of the *.raw files in the Catalog window, then click [Select]. In
the Read Parameters window, click [OK]. Back in the SBMAX64 window, click
[Echogram] to open the echogram window(s).

Once in the Echogram window, click [Export]. In the Save dialog, choose the desired
folder to save the exported files, then click [Select Folder]. The program exports each
sample as a number, and data is grouped into rows by ping.

As you can see, each file contains intensity data from a single depth channel. File names
are in the format of RawFileName.RAW_Channel#.txt.

SBMAX64 - RAWO0710.LOG - Depth | = | Raw
File Edit View Tools Help - Home Share View
Survey Files %
Cut © )
SCHE x| A . - X =]
= * W..| Copy path 'a h
. Pinto Quick Copy Paste Move  Copy Delete Rename New Properties
| Draw Selected Files Only FroEESS [7] Paste shortcut to~ to~ - folder -
Select Al 1 1 K Clipboard Organize New Ot
« v 1 « HYPACK 2023 » Projects » Single Beam Mobile » Raw v
“ Name Date modified Type
e [5] 302P38 RAW_Channel2.txt 7/31/2023 2:45 PM Text D
_ |Dune | € |1 302P38.RAW Channel1.txt 7/31/2023 2:45 PM Text D
© 302P38 0001.RAW 5/23/2023 3:05 PM RAW f
Speed Profile | B |&] 302P38.RAW 2/3/2023 3:08 PM RAW f
M T Spreadsheet | [ ] 302P388IN 8/30/2012 1:59 PM BIN Fil
= — | [ 1 310P00.BIN 8/30/2012 1:58 PM BIN Fil
chogram
L] [ ] 305P00.BIN 8/30/2012 1:58 PM BIN Fil
sV - = A e e e R

14



64-8IT HYSWEEP® EDITOR (MBMAX64)

» The HYPACK 2023 Q2 release introduced the option to add custom accuracy
standards to the TPU Editor. These custom accuracy standards can now be read in
MBMAX64 and used in HYSWEEP CUBE, auto-filters, and in matrix display/export.

Read Parameters X

Survey Corrections Devices Processing

Survey

Depth Mode Elevation Mode Load Sidescan (if available)

Select Frequency
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To use a custom accuracy standard from the TPU Editor in MBMAX64, from the HYPACK
Shell click HYSWEEP -> HYSWEEP Editor (64-bit) to open MBMAX64. In MBMAX64,
click Load Survey, select the desired LOG and RAW files, and in the Read Parameters

window under the TPU section, select the custom accuracy standard from the Accuracy
Standard drop down menu.

For more information on adding custom standards in the TPU editor, refer to Custom
Devices and Standards in the TPU Editor by Jocelyn Kane.

FINAL PRODUCTS

HYPLOT MAX

e Users can now select multiple charts and reorder them together in the Draw Order
tab under the Charts section. To select more than one chart, hold CTRL and click on
the chart names, then click [Front] or [Back] to move them. The following images show
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this behavior - the left image shows the selected charts, the right image shows the order
of the charts after the top [Back] button has been clicked.
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CROSS SECTIONS AND VOLUMES

e Added the Smoothing and Range options to Beach Variable Design Template in the
Graph Options -> Volume tab. Check “Smoothing” to connect the variable design
template segments at their intersections. Check “Range” to limit this feature to
intersections with a DBL value within +/- the value of the user-entered number from the
original intersection of the two segments. The template segments are only smoothed if
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the intersection line touches the segment within its points.

File Help
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An example of smoothing applied to a beach variable design template is shown below.
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TIN MODEL

* Fixed an issue where checking Show Picture in the Export window resulted in
nothing displaying in the in the picture area of the Volumes dialog. Now, when Show
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Picture is checked, the channel, lines, and borders are shown while volumes are
calculated, and the TIN model will be drawn when calculations finish.

The TIN Model program now displays the warning message “Ignored templates,
complex lines” next to the file name in the main window if a *.Inw is loaded with
templates but has lines with more than two points. Note that templates cannot be
displayed with complex lines.
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The 2D Section View Parameters dialog has been updated to display section names
instead of the section index.
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ENC EDITOR

Added support for *.tgt and *.kmz files both for SHOM AML dialog and in general import
dialog.

Attribute editor now allows editing of string type attributes in a memo component, making
it easier to edit lengthy text data.

Colored elements in SHOM AML tree: Red: show stopper! Yellow: Warns of missing
source file. Green: All good.

Moved Boundaries tree item to the top to show its importance.

Completion message at end of process.

Corrected format specifiers inside hySchema.hsf.

Added name builder behavior and protective marking attribute to SHOM AML dialog.
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e Remarks from hySchema.hsf displayed in Attribute Editor for Code String attribute types.

e Double click to edit Spatial Attribute.

e Proper handling of Agency attribute.

 Removed side effects, both potential and actual, from editing attributes from multiple
points inside the UI.

e Added a “TIN Import” item to the SHOM AML dialog. Allows the user to select a TIN
generated *.dxf file and run the TIN Import routine upon it. This routine creates Depth
Areas and Depth Contours in the final chart.

e Cosmetic Change - Iltem “TIN Import” renamed “Depth Contour” and moved under the
CLB branch.
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