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Targeting and Mosaicking Walkthrough
By Daniel Tobin
This tutorial will give a basic walkthrough of how to load, process, and mosaic your side scan 
sonar data. This document is laid out so you can follow along with your own data.
To open the Targeting and Mosaicking program, launch HYPACK® and click Targeting and 
Mosaicking (Beta) from the Side Scan menu.

LOAD SOME DATA
Click File -> Open and then choose your data. Unprocessed data (data collected during your 
survey) is stored in your project's Raw folder, while data you've processed or edited before is 
stored in the Edit folder.

READ PARAMETERS

After you choose your data, the Read Parameters window appears. In the Selections tab, 
choose the navigation and heading data to use from the dropdown menus. The remaining 
tabs can generally be safely ignored.
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If your loaded heading or position data looks wrong, reload the data and choose a different 
heading or navigation device.

BOTTOM TRACKING
Knowing the bottom of your survey is critical for accurate targeting and mosaicking. If the 
original data does not include bottom data, we can find it by using bottom tracking.
In the Side Scan Targeting and Mosaicking window, go to the Altitude tab. If you can't find the 
Altitude window, click the “1” button on the left side under Stages. You should see the 
following series of controls on the left side of this window.

There is a toggle to show either the port or starboard side at the top. Whichever is selected 
will appear in the data window to the right.
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If you don't see any data or it looks too bright or too dark, you may need to adjust your image 
settings. Scroll down to the Link to Image Settings section in this article to see tips and 
instructions.

ZOOM CONTROLS

The buttons on the left half are used for zooming in and out of the data horizontally or 

vertically. Using the vertical zoom tool  will require clicking and dragging the data to 

mark where you'd like to zoom, while the horizontal zoom tool  will zoom in at fixed 
increments with every click. The buttons beneath each of those will zoom out.

MANUAL DIGITIZING 

Digitizing means finding and marking the bottom in your data. On the right half of the control 
panel are buttons used for manual digitizing. Before you try manual digitizing, try the 
techniques in the Auto Bottom Detection section below.

If you click the digitize button , you will enter digitize mode. Now, when you click on the 
data, you'll mark where you click as the bottom for that ping. If you click multiple times, you'll 
create a series of dots. Try your best to click along the bottom as accurately as possible. Use 
the zoom tools to improve accuracy.

When you're finished digitizing, click the digitize button again and your new bottom will be 
applied to the data.

You can also use the smooth button  to smooth your bottom tracking. Lastly, the up and 
down arrows will shift your bottom tracking up or down by 1%.
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AUTO BOTTOM DETECTION

Beneath these controls is the Auto Bottom Detection window. This tool can be used to 
automatically find the bottom across your data and is useful for digitizing large or complex 
files.

Set Blanking to the depth at which you start seeing the bottom, or the depth that noise in the 
water column drops. You can see the depth your cursor is at by looking at the top left of the 
Altitude window.
Gate Size can generally be left as it is. Set Sensitivity to the middle - you'll adjust this later 
after seeing the results of Auto Bottom Detection. Click Apply to overwrite your depth 
measurements with auto-detected altitude.
If your bottom detection is too high, double check your Blanking setting - you may need to 
increase it to clear any noise in the water column. If that doesn't help, try decreasing the 
Sensitivity slider. If your bottom detection is too low, increase the Sensitivity slider.
You can also go back to Manual Digitizing, above, to manually correct areas of poor bottom 

tracking. You may also want to apply smoothing  afterwards as well.

HEADING
The Heading window shows your data's heading over time. You can find the Heading window 
by either clicking its tab along the top or by clicking '1' under Stages at the top left of the 
program.
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There is a smoothing button at the top left of the window that can filter out bumps and hitches 
in heading, which will make for a cleaner output mosaic at the end.

POSITION
The Survey window shows your position data for all loaded lines. The Survey window can be 
found by clicking its tab along the top or clicking the '1' button under Stages. The currently 
selected line is highlighted in blue. You can click in the window to select and view other lines.

Like the Heading window, this window also has a smoothing tool at the top left. Click this to 
smooth your position data, which will help create a nicer final mosaic later.
October / 2023  5



POSITION EDITING

You can also manually edit positions in this window. Click and drag a box in the window to 
select a section of position data you wish to edit. Several buttons should be enabled now.

You can use the buttons under Positions to delete position data either inside or outside of 
your selected box. This can be useful for removing chunks of erroneous position data.
You can also mark sections of imagery to be hidden using the Imagery box. This can be 
useful to block out areas of your data that are not relevant.

MARKING TARGETS
Select the Scanview tab, select '2' under the Stages menu, or select 'S+A' under the Stages 
menu to see the Scanview window. Scanview displays all your data in a "waterfall". If you 
need to adjust how your imagery looks, now might be a good time to jump ahead to the 
Image Settings section.
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To mark a target, double-click in the Scanview window where you'd like your target to be 
marked. This will open the New Target window.

Along the left you can edit the target name and its details.
If you click and drag on the data, you'll fill the measurement into the Length field 
automatically. If you click in the Width field and then click and drag on the data, you'll fill that 
field instead with your measurement.

TARGETING TOOLS

Along the bottom are a series of controls. The first few are some basic zoom controls.

The camera button  lets you select an area to save as an image associated with this 
target. Click the camera button, then click and drag in the data to mark the area you'd like to 
save alongside this target. The area you select is automatically saved and associated with 
this target.

There is also a retarget button . Click this and then click anywhere in the image to 
change the target's location.
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ALTITUDE, RANGE, AND HEIGHT

Along the top is a section for measuring altitude, range, and height.

The altitude and range should automatically be set when you mark the target. The height will 
need to be adjusted to get an accurate measurement. Click and drag the bar labeled Height. 
A vertical indicator will appear in the data. Drag the slider to the end of the shadow of 
whatever object you're measuring to get a height measurement.

TARGET CLASSIFICATION

Target classifications allow you to group sets of targets together based on their contents. For 
example, you may have classifications for tires, cars, buoys, and crab pots.
At the bottom left of the New Target window is a list of customizable classifications. If the list 
is empty, click the [...] next to open the Target Comparison window, where you can add 
classifications.
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This window also lets you see previous targets that have been added to this classification 
and had their images marked to be included in the comparison tool.

Click the dropdown menu to add a new classification.

When choosing a classification, images previously categorized in that classification will be 
displayed on the right. You can use the arrows to switch through them to help when choosing 
a classification. Once you choose or add a classification, you can set a confidence level and 
optionally add your target's image to that classification by clicking Add Image to Code.
Click [Close] to close the Target Comparison window. Then, click [Save Target and Image] to 
close the New Target window and mark your target.

TARGET VIEWER

Under Tools -> Target Viewer, you can see all targets you've previously marked in the 
program for this project. You can select multiple targets to export into an RTF file by clicking 

the RTF export button .

IMAGE SETTINGS
Imagery in side scan data is very subjective - in the same way taking and editing a photo is 
subjective. The image settings below let you modify your imagery to your liking. Play with 
these a lot until you find settings you like that shows your data in the best light.
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Right-click on the data and select Side Scan Controls or click the Side Scan Controls button 

 at the top left of the program.

PREVIEW WINDOW AND SLIDERS

Along the right is a preview window showing some imagery and its corresponding signal 
graph. On the signal graph there are some sliders that can be dragged up or down to adjust 
the brightness of your data. There are also sliders at the bottom of the graph that can be used 
to adjust the black point of your data.
If you don't see the signal graph, try clicking the up or down arrows to its left a few times or 
click the zoom extents button beneath the arrows.

COLORS

On the Colors menu, you can change the color, brightness, and contrast for your imagery.
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GAIN

Gain is a key tool to creating effective side scan images. Gain is used to strengthen and 
brighten the weaker signal at the edges of your swath, creating an even brightness across. 
There are several gain options available.

Basic Gains should be avoided.
Auto TVG is a great “one and done” solution - selecting this can give you a very serviceable 
image quickly. After selecting this, you can adjust the brightness by changing its Sensitivity 
slider.
dBs/100 Meters is a more manual solution that can help avoid some of the artifacts you might 
see if you use Auto TVG. Adjust its slider so the signal graph is mostly flat across the swath - 
the signal should not be “smiling” or “frowning”.
Smiling:

Frowning:
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Flat:

The next option, the formula option, is good for more advanced signal tuning.
The final option, Angle Varied Gain, is another “one and done” option. After selecting it, you'll 
need to adjust the sliders on the signal graph to your liking, but it will try to even out 
brightness across the swath.
Different gain options will work better for different sonars and datasets. Be sure to adjust the 
sliders on the graph to your liking. Remember to use the bottom sliders on the graph as well.

DISPLAY

The last page shows a list of display options. Most of these are self-explanatory.

The last option, “Blank imagery adjacent to nadir”, does require some explanation. This 
setting will make the area right adjacent to the bottom totally transparent up to a certain 
amount during the final mosaic step. This is useful when your data includes side lobes, or 
bright streaks near the nadir.
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MOSAICKING
Mosaicking is where every sample from your side scan data is mapped to world coordinates, 
like placing tiles in a mosaic. This is often the "final step" for a lot of side scan data 
processing.
Click the Mosaic tab at the top or click the '3' button under Stages at the top left.

The Lines section allows you to select which files you've loaded you want included in this 
mosaic.
The Resolution section allows you to set how much area a single pixel should cover. As you 
change the area per pixel, note the dimensions, memory use, and number of tiles. Higher 
area values mean a single pixel covers more area, meaning fewer pixels overall in the image. 
To get a more detailed image, set the area per pixel lower.
Overlapping Areas determines what a pixel should do if it's been mapped on top of another 
pixel. This generally occurs when two adjacent lines overlap. The options determine if the 
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brightest or dimmest value is kept, if the values are averaged, or if the latter pixel should just 
overlay on top of the earlier pixel.
Fill Gaps and Remove Water Column should remain checked for best results.
Filters allows you to apply a selection of filters over the final image.
You can include a border file as well, to crop your image.
The Frequency selector allows you to choose which frequency you'll mosaic if your dataset 
has multiple frequencies.
Finally, you can choose the output file's name. Optionally, you can have each line create its 
own mosaic using the checkbox above the file name.
Click [Make Mosaic] to generate a mosaic image. 

TIPS AND ADVICE
Make lots and lots of mosaics. They're quick, easy, and fun to make once you've learned the 
basics. The more you make, the better you'll get at it. Keep playing with settings until you 
create an image you like. Setting the area per pixel value higher under the Resolution section 
in the Mosaic step will allow you to create mosaics faster, albeit at a lower resolution. Once 
you have decent coloring, you can decrease the area per pixel to get a higher resolution 
image.
Any changes to bottom track, heading, or position can all be undone with Ctrl+Z or Tools -> 
Undo.
Keep exploring different parts of the program. Not every feature in Targeting and Mosaicking 
was reviewed in this article, like the Spreadsheet or Pitch/Roll windows. There's more tools 
and windows in the main menu at the top of the program, too.
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